• Quote of the Day
    "Plant your own garden and decorate your own soul, instead of waiting for someone to bring you flowers."
    Veronica A. Shoffstall, After a While (1971), posted by David Baxter

gooblax

MVP
Joined
Aug 4, 2007
Messages
3,601
Points
113
FYI I get a security certificate has expired error for the site, expiry date 28 Dec 2021. The site refuses to load on Chrome, loads the error on Edge - I clicked 'proceed anyway' to be able to view the site, log in and post this (multiple devices).
 

David Baxter

Administrator
Joined
Mar 26, 2004
Messages
38,082
Points
113

David Baxter

Administrator
Joined
Mar 26, 2004
Messages
38,082
Points
113
I just switched from the default cPanel security certificate to Let's Encrypt certificates. This c orrectly cascaded from psychlinks.ca down to forum.psychlinks.ca so you should no longer be seeing that error.

Can those of you who encountered the problem please report back here to confirm the fix?
 

Daniel

Forum Supporter
MVP
Joined
Aug 5, 2004
Messages
19,988
Points
113
It works now, even in Chrome and Safari where I didn't bypass the security message earlier.
 

David Baxter

Administrator
Joined
Mar 26, 2004
Messages
38,082
Points
113
Thanks, Daniel.

The previous certificate changed somewhere between September 2021 and no when it renewed the certificate: it no longer provides full "wildcard" certificates. So where previously, all variations were automatically included, now it does not correctly cover subdomains.

Fortunately, there is a cPanel plugin that makes swwitching to Let's Encrypt almost effortless. :)
 

David Baxter

Administrator
Joined
Mar 26, 2004
Messages
38,082
Points
113
Thank you all for bringing this to my attention. cPanel seems to have changed the source of their default security and that brought the problem to a head.
 

Latest posts


Top Bottom